Managing issues with installing Phenix SDKs

Some issues with installing the latest Phenix web SDK are caused by the NPM version. Phenix supports version 6.14.11. Version 7 or above is not supported at this time.

Check your version of npm by running npm version

When using an unsupported version of NPM, the user receives an error when installing:

 

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 error ~/…/node_modules/phenix-web-sdk: Command failed. Exit code: 1 Command: npm prune Arguments: Directory: /…/node_modules/phenix-web-sdk Output: npm ERR! code ERESOLVE npm ERR! ERESOLVE unable to resolve dependency tree npm ERR! npm ERR! While resolving: phenix-web-sdk@2021.0.12 npm ERR! Found: grunt@1.2.1 npm ERR! node_modules/grunt npm ERR! dev grunt@"1.2.1" from the root project npm ERR! npm ERR! Could not resolve dependency: npm ERR! peer grunt@"~0.4" from grunt-sed@0.1.1 npm ERR! node_modules/grunt-sed npm ERR! dev grunt-sed@"0.1.1" from the root project npm ERR! npm ERR! Fix the upstream dependency conflict, or retry npm ERR! this command with --force, or --legacy-peer-deps npm ERR! to accept an incorrect (and potentially broken) dependency resolution. npm ERR! npm ERR! See ~/.npm/eresolve-report.txt for a full report.